import re
regex = re.compile(r"c:(?:(?<category_id>\d+\b)|(\"?)(?<category_name>(?:[^\"\s]+|[^\"]+))\2)")
test_str = "python c:192 c:1Stackoverflow c:\"Stack Overflow2\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")