package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*(\|)\s*`)
var str = ` текст текст | текст текст текст | текст текст `
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}