$re = '/\s*(\|)\s*/m';
$str = ' текст текст | текст текст текст | текст текст ';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;