re = /\s*(\|)\s*/m
str = ' текст текст | текст текст текст | текст текст '
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result