using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:^|\|).*?(?:\||$)[^\s\|]*)|\s";
string substitution = @"$1";
string input = @" текст текст | текст текст текст | текст текст
";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}