const regex = /((?:^|\|).*?(?:\||$)[^\s\|]*)|\s/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:^|\\|).*?(?:\\||$)[^\\s\\|]*)|\\s', 'gs')
const str = ` текст текст | текст текст текст | текст текст
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);