$re = '/((?:^|\|).*?(?:\||$)[^\s\|]*)|\s/s';
$str = ' текст текст | текст текст текст | текст текст
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;