package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*)?:(.*)?:(.*)?:(.*)?:(.*)?$`)
var str = `google:cpc:click_campaign:123:golf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}