re = /^(.*)?:(.*)?:(.*)?:(.*)?:(.*)?$/m
str = 'google:cpc:click_campaign:123:golf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end