$re = '/^(.*)?:(.*)?:(.*)?:(.*)?:(.*)?$/m';
$str = 'google:cpc:click_campaign:123:golf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);