$re = '`(?s)> \[!(CAUTION|IMPORTANT|NOTE|TIP|WARNING)\].*?(\n|$)`m';
$str = '> [!NOTE]
> This is a note
> [!WARNING]
> THis is a warning';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);