re = /(?s)> \[!(CAUTION|IMPORTANT|NOTE|TIP|WARNING)\].*?(\n|$)/m
str = '> [!NOTE]
> This is a note
> [!WARNING]
> THis is a warning'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end