import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(你知道)?#的?(简介|介绍|知识)(吗|不|嘛|么)?$";
final String string = "介绍一下#\n"
+ "给我说说#\n"
+ "给我介绍一下#吧\n\n"
+ "说说#是什么\n"
+ "介绍一下#是啥\n"
+ "什么是#\n"
+ "#是啥啊\n\n"
+ "#的简介\n"
+ "你知道#的知识吗";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}