use strict;
my $str = '介绍一下#
给我说说#
给我介绍一下#吧
说说#是什么
介绍一下#是啥
什么是#
#是啥啊
#的简介
你知道#的知识吗';
my $regex = qr/^(你知道)?#的?(简介|介绍|知识)(吗|不|嘛|么)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}