# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=Страна)|(?=Производитель)|(?=Артикул расширенный)|(?=Ед\.измерения)"
test_str = "Класс: Кабели с медной токопроводящей жилой Страна: Россия Производитель: Кабэкс Артикул расширенный: ТХМ00353683 Ед.измерения: м Упаковки: 100 м Сертификат: RU C-RU.АЖ03.B00054-19 Тип изделия : Кабель Марка : ВВГнг-LS Количество жил : 3 Сечение жилы, мм2 : 1.5 Напряжение, В : 660 Исполнение : нг-LS Материал оболочки : ПВХ пониженной горючести с низким дымо-газовыделением Материал изоляции : ПВХ пластикат пониженной пожароопасности с низким дымо-газовыделением"
subst = "; "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.