import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\d+(\\d{1,3})*([\\,\\ ]\\d{3})*\\.\\d+)?.+(sqft)";
final String string = "\"4,882 \\t\\t\\t\\t\\t\\tsqft \\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t/ \\t\\t\\t\\t\\t\\t\\t\\t\\t\\t454 \\t\\t\\t\\t\\t\\tsqm\"\n"
+ "\"4,882 \\t\\t\\t\\t\\t\\tsqft \\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t/ \\t\\t\\t\\t\\t\\t\\t\\t\\t\\t454 \\t\\t\\t\\t\\t\\tsqm\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}