import Foundation
let pattern = #"(?:\d+(\d{1,3})*([\,\ ]\d{3})*\.\d+)?.+(sqft)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"4,882 \t\t\t\t\t\tsqft \t\t\t\t\t\t\t\t\t\t\t\t\t\t\t/ \t\t\t\t\t\t\t\t\t\t454 \t\t\t\t\t\tsqm"
"4,882 \t\t\t\t\t\tsqft \t\t\t\t\t\t\t\t\t\t\t\t\t\t\t/ \t\t\t\t\t\t\t\t\t\t454 \t\t\t\t\t\tsqm"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)