re = /(?:\d+(\d{1,3})*([\,\ ]\d{3})*\.\d+)?.+(sqft)/m
str = '"4,882 \\t\\t\\t\\t\\t\\tsqft \\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t/ \\t\\t\\t\\t\\t\\t\\t\\t\\t\\t454 \\t\\t\\t\\t\\t\\tsqm"
"4,882 \\t\\t\\t\\t\\t\\tsqft \\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t\\t/ \\t\\t\\t\\t\\t\\t\\t\\t\\t\\t454 \\t\\t\\t\\t\\t\\tsqm"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end