#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)/+[^\s/]+"
Local $sString = "/this/is//an example of what i want /to///do" & @CRLF & _
"/this/is//an example of what i want to /do"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)