$re = '//+[^\s/]+/m';
$str = '/this/is//an example of what i want /to///do
/this/is//an example of what i want to /do';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;