import re
regex = re.compile(r"/+[^\s/]+", flags=re.MULTILINE)
test_str = ("/this/is//an example of what i want /to///do\n"
"/this/is//an example of what i want to /do")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)