using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i).* msiexec.*:\\\\";
string input = @"cmd.exe msiexec.exe:\\ someprogram -argument ""stuff""
MSI Exec Web install
SysmonEvent | where (EventID == 1 and (CommandLine matches regex @'(?i).* msiexec.*:\\/\\/.*'))
SecurityEvent | where (EventID == 4688 and (ProcessCommandLine matches regex @'(?i).* msiexec.*:\\/\\/.*'))";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}