import re
regex = re.compile(r"(?i).* msiexec.*:\\\\", flags=re.MULTILINE)
test_str = ("cmd.exe msiexec.exe:\\\\ someprogram -argument \"stuff\"\n\n"
"MSI Exec Web install\n"
"SysmonEvent | where (EventID == 1 and (CommandLine matches regex @'(?i).* msiexec.*:\\\\/\\\\/.*'))\n"
"SecurityEvent | where (EventID == 4688 and (ProcessCommandLine matches regex @'(?i).* msiexec.*:\\\\/\\\\/.*'))")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")