#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^0$|^[1-9](?:[0-9]{3}|[0-9]{19}|[0-9]{24})$|^[0-9][1-9](?:[0-9]{2}|[0-9]{18}|[0-9]{23})$|^[0-9]{2}[1-9](?:[0-9]|[0-9]{17}|[0-9]{22})$|^[0-9]{3}[1-9](?:|[0-9]{16}|[0-9]{21})$|^[0-9]{4}[1-9](?:[0-9]{15}|[0-9]{20})$|^[0-9]{5}[1-9](?:[0-9]{14}|[0-9]{19})$|^[0-9]{6}[1-9](?:[0-9]{13}|[0-9]{18})$|^[0-9]{7}[1-9](?:[0-9]{12}|[0-9]{17})$|^[0-9]{8}[1-9](?:[0-9]{11}|[0-9]{16})$|^[0-9]{9}[1-9](?:[0-9]{10}|[0-9]{15})$|^[0-9]{10}[1-9](?:[0-9]{9}|[0-9]{14})$|^[0-9]{11}[1-9](?:[0-9]{8}|[0-9]{13})$|^[0-9]{12}[1-9](?:[0-9]{7}|[0-9]{12})$|^[0-9]{13}[1-9](?:[0-9]{6}|[0-9]{11})$|^[0-9]{14}[1-9](?:[0-9]{5}|[0-9]{10})$|^[0-9]{15}[1-9](?:[0-9]{4}|[0-9]{9})$|^[0-9]{16}[1-9](?:[0-9]{3}|[0-9]{8})$|^[0-9]{17}[1-9](?:[0-9]{2}|[0-9]{7})$|^[0-9]{18}[1-9](?:[0-9]|[0-9]{6})$|^[0-9]{19}[1-9](?:|[0-9]{10})$|^[0-9]{20}[1-9][0-9]{4}$|^[0-9]{21}[1-9][0-9]{3}$|^[0-9]{22}[1-9][0-9]{2}$|^[0-9]{23}[1-9][0-9]$|^[0-9]{24}[1-9]$"
Local $sString = "0" & @CRLF & _
"1" & @CRLF & _
"11" & @CRLF & _
"111" & @CRLF & _
"0100" & @CRLF & _
"0000" & @CRLF & _
"00000000000000000000" & @CRLF & _
"01001010100110010010" & @CRLF & _
"0000000000000000000000000" & @CRLF & _
"0100101010011010201301122"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")