import Foundation
let pattern = #"^0$|^[1-9](?:[0-9]{3}|[0-9]{19}|[0-9]{24})$|^[0-9][1-9](?:[0-9]{2}|[0-9]{18}|[0-9]{23})$|^[0-9]{2}[1-9](?:[0-9]|[0-9]{17}|[0-9]{22})$|^[0-9]{3}[1-9](?:|[0-9]{16}|[0-9]{21})$|^[0-9]{4}[1-9](?:[0-9]{15}|[0-9]{20})$|^[0-9]{5}[1-9](?:[0-9]{14}|[0-9]{19})$|^[0-9]{6}[1-9](?:[0-9]{13}|[0-9]{18})$|^[0-9]{7}[1-9](?:[0-9]{12}|[0-9]{17})$|^[0-9]{8}[1-9](?:[0-9]{11}|[0-9]{16})$|^[0-9]{9}[1-9](?:[0-9]{10}|[0-9]{15})$|^[0-9]{10}[1-9](?:[0-9]{9}|[0-9]{14})$|^[0-9]{11}[1-9](?:[0-9]{8}|[0-9]{13})$|^[0-9]{12}[1-9](?:[0-9]{7}|[0-9]{12})$|^[0-9]{13}[1-9](?:[0-9]{6}|[0-9]{11})$|^[0-9]{14}[1-9](?:[0-9]{5}|[0-9]{10})$|^[0-9]{15}[1-9](?:[0-9]{4}|[0-9]{9})$|^[0-9]{16}[1-9](?:[0-9]{3}|[0-9]{8})$|^[0-9]{17}[1-9](?:[0-9]{2}|[0-9]{7})$|^[0-9]{18}[1-9](?:[0-9]|[0-9]{6})$|^[0-9]{19}[1-9](?:|[0-9]{10})$|^[0-9]{20}[1-9][0-9]{4}$|^[0-9]{21}[1-9][0-9]{3}$|^[0-9]{22}[1-9][0-9]{2}$|^[0-9]{23}[1-9][0-9]$|^[0-9]{24}[1-9]$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0
1
11
111
0100
0000
00000000000000000000
01001010100110010010
0000000000000000000000000
0100101010011010201301122
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)