# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^0$|^[1-9](?:[0-9]{3}|[0-9]{19}|[0-9]{24})$|^[0-9][1-9](?:[0-9]{2}|[0-9]{18}|[0-9]{23})$|^[0-9]{2}[1-9](?:[0-9]|[0-9]{17}|[0-9]{22})$|^[0-9]{3}[1-9](?:|[0-9]{16}|[0-9]{21})$|^[0-9]{4}[1-9](?:[0-9]{15}|[0-9]{20})$|^[0-9]{5}[1-9](?:[0-9]{14}|[0-9]{19})$|^[0-9]{6}[1-9](?:[0-9]{13}|[0-9]{18})$|^[0-9]{7}[1-9](?:[0-9]{12}|[0-9]{17})$|^[0-9]{8}[1-9](?:[0-9]{11}|[0-9]{16})$|^[0-9]{9}[1-9](?:[0-9]{10}|[0-9]{15})$|^[0-9]{10}[1-9](?:[0-9]{9}|[0-9]{14})$|^[0-9]{11}[1-9](?:[0-9]{8}|[0-9]{13})$|^[0-9]{12}[1-9](?:[0-9]{7}|[0-9]{12})$|^[0-9]{13}[1-9](?:[0-9]{6}|[0-9]{11})$|^[0-9]{14}[1-9](?:[0-9]{5}|[0-9]{10})$|^[0-9]{15}[1-9](?:[0-9]{4}|[0-9]{9})$|^[0-9]{16}[1-9](?:[0-9]{3}|[0-9]{8})$|^[0-9]{17}[1-9](?:[0-9]{2}|[0-9]{7})$|^[0-9]{18}[1-9](?:[0-9]|[0-9]{6})$|^[0-9]{19}[1-9](?:|[0-9]{10})$|^[0-9]{20}[1-9][0-9]{4}$|^[0-9]{21}[1-9][0-9]{3}$|^[0-9]{22}[1-9][0-9]{2}$|^[0-9]{23}[1-9][0-9]$|^[0-9]{24}[1-9]$"
test_str = ("0\n"
"1\n"
"11\n"
"111\n"
"0100\n"
"0000\n"
"00000000000000000000\n"
"01001010100110010010\n"
"0000000000000000000000000\n"
"0100101010011010201301122")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.