using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Za-z ]+ [A-Za-z ]+ @[A-Za-z ]+ \d+ \d+";
string input = @"Band Name @Venue 30 450";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}