package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Za-z ]+ [A-Za-z ]+ @[A-Za-z ]+ \d+ \d+`)
var str = `Band Name @Venue 30 450`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}