$re = '/[A-Za-z ]+ [A-Za-z ]+ @[A-Za-z ]+ \d+ \d+/';
$str = 'Band Name @Venue 30 450';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);