package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\D\d{3}\s?`)
var str = `4473 333hello 564 394844he hello
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}