using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{#(.*?)}";
string input = @"This is just a test {#3,2,7,9} this is another test {#21,2,11}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}