$re = '/{#(.*?)}/m';
$str = 'This is just a test {#3,2,7,9} this is another test {#21,2,11}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);