re = /{#(.*?)}/m
str = 'This is just a test {#3,2,7,9} this is another test {#21,2,11}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end