#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z][0-9][a-zA-Z0-9](?:\.[a-zA-Z0-9]{1,4})?$"
Local $sString = "A12.0" & @CRLF & _
"A12.A9" & @CRLF & _
"A12.A9A9" & @CRLF & _
"A12.ZZZZ" & @CRLF & _
"A12.9999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")