package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z][0-9][a-zA-Z0-9](?:\.[a-zA-Z0-9]{1,4})?$`)
var str = `A12.0
A12.A9
A12.A9A9
A12.ZZZZ
A12.9999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}