re = /^[A-Za-z][0-9][a-zA-Z0-9](?:\.[a-zA-Z0-9]{1,4})?$/m
str = 'A12.0
A12.A9
A12.A9A9
A12.ZZZZ
A12.9999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end