package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\pL\pM'-]+`)
var str = `Raphaël said you aren't coming home.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}