$re = '/[\pL\pM\'-]+/u';
$str = 'Raphaƫl said you aren\'t coming home.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);