const regex = /[\pL\pM'-]+/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\pL\\pM\'-]+', 'gu')
const str = `Raphaƫl said you aren't coming home.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}