# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=^|\s)(?:(\w*')?)(@(\S+))/<a href="\/user\/$3">$2<\/a>/gm;t' <<< "1. take this -> @Mark
2. take this -> @mark_2
3. take this -> @中国
4. take this -> l'@antro
5. don't take this -> 中国@中国.zh
6. don't take this -> 中国@google.zh
7. don't take this -> info@google.com
8. don't take this -> 99@test.com
9. don't take this -> 99@user
10. don't take this -> %&@user
11. take this -> dell'@altro
12. take this -> l'@mike"