import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|\\s)(?:(\\w*')?)(@(\\S+))";
final String string = "1. take this -> @Mark\n"
+ "2. take this -> @mark_2\n"
+ "3. take this -> @中国\n"
+ "4. take this -> l'@antro\n"
+ "5. don't take this -> 中国@中国.zh\n"
+ "6. don't take this -> 中国@google.zh\n"
+ "7. don't take this -> info@google.com\n"
+ "8. don't take this -> 99@test.com\n"
+ "9. don't take this -> 99@user\n"
+ "10. don't take this -> %&@user\n"
+ "11. take this -> dell'@altro\n"
+ "12. take this -> l'@mike";
final String subst = "<a href=\"/user/$3\">$2</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}