# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=^|\s)(?:(\w*')?)(@(\S+))"
test_str = ("1. take this -> @Mark\n"
"2. take this -> @mark_2\n"
"3. take this -> @中国\n"
"4. take this -> l'@antro\n"
"5. don't take this -> 中国@中国.zh\n"
"6. don't take this -> 中国@google.zh\n"
"7. don't take this -> info@google.com\n"
"8. don't take this -> 99@test.com\n"
"9. don't take this -> 99@user\n"
"10. don't take this -> %&@user\n"
"11. take this -> dell'@altro\n"
"12. take this -> l'@mike")
subst = "<a href=\"/user/$3\">$2</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.