using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(P\w+)\W(P\w+)";
string input = @"Python PHP"", ""Java JavaScript"", ""c c++""
(P\w+)\W(P\w+)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}