package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(P\w+)\W(P\w+)`)
var str = `Python PHP", "Java JavaScript", "c c++"
(P\w+)\W(P\w+)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}