package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^省]+省|.+自治区|[^市]+市)([^自治州]+自治州|[^市]+市|[^盟]+盟|[^地区]+地区)([^市]+市|[^县]+县|[^旗]+旗|.+区|.+镇|.+街道)`)
var str = `广东自治区河源市紫金街道黄洞村竹头25号`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}