import Foundation
let pattern = #"([^省]+省|.+自治区|[^市]+市)([^自治州]+自治州|[^市]+市|[^盟]+盟|[^地区]+地区)([^市]+市|[^县]+县|[^旗]+旗|.+区|.+镇|.+街道)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"广东自治区河源市紫金街道黄洞村竹头25号"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}