$re = '/([^省]+省|.+自治区|[^市]+市)([^自治州]+自治州|[^市]+市|[^盟]+盟|[^地区]+地区)([^市]+市|[^县]+县|[^旗]+旗|.+区|.+镇|.+街道)/';
$str = '广东自治区河源市紫金街道黄洞村竹头25号';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);