const regex = new RegExp('\\d{3,3}\\d{1,3}\\d{1,3}\\d{1,3}', 'gm')
const str = `<tr>
<td>99</td>
<td>Name</td>
<td>ЕГЭ</td>
<td>268</td><td>90</td><td>91</td><td>87</td>
<td></td>
<td>Копия</td>
<td>Нет</td>
</tr>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}