use strict;
my $str = '<tr>
<td>99</td>
<td>Name</td>
<td>ЕГЭ</td>
<td>268</td><td>90</td><td>91</td><td>87</td>
<td></td>
<td>Копия</td>
<td>Нет</td>
</tr>';
my $regex = qr/\d{3,3}\d{1,3}\d{1,3}\d{1,3}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}