using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+).+?(\S*?(?=\1)\S*?)$";
string input = @"ABCD 19475ABCD_97jdhgbl
ABCD 19475ABC_97jdhgbl
CDEF 87437862AB83742kh";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}